Get rid of annoying rubber error: DeprecationWarning: md5 ...

https://bugzilla.redhat.com/show_bug.cgi?id=506053
the patch is: http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=5;filename=python2.6.patch;att=1;bug=520048

To get rid of the annoying rubber deprecation warning of a deprecated use of the md5 library, open /usr/share/rubber/rubber/util.py and change:

import md5
m = md5.new()

to

import hashlib
m = hashlib.md5()

Comments