QtiPlot on Ubuntu

newer debian build

Get the debian build (that is newer than the version shipped with Ubuntu 9.10):

sudo apt-get install liborigin2-1
cd ~/Downloads
wget http://ftp.de.debian.org/debian/pool/main/q/qtiplot/qtiplot_0.9.7.8-1_amd64.deb
sudo dpkg -i --force-depends qtiplot_0.9.7.8-1_amd64.deb

or for i386 platform:

sudo apt-get install liborigin2-1
cd ~/Downloads
wget http://ftp.de.debian.org/debian/pool/main/q/qtiplot/qtiplot_0.9.7.8-1_i386.deb
sudo dpkg -i --force-depends qtiplot_0.9.7.8-1_i386.deb

change the dependencies of the .deb file

you might also change the dependencies of the debian .deb file found here. This is some advanced stuff as it involves extracting the debian package, changing the file DEBIAN/control and reassembling the package again:

cd ~/Downloads
mkdir qtiplot
cd qtiplot
wget http://ftp.de.debian.org/debian/pool/main/q/qtiplot/qtiplot_0.9.7.8-1_i386.deb
dpkg -e qtiplot_0.9.7.8-1_i386.deb
cd DEBIAN/
gedit control

Now change the dependencies (using the editor gedit) to:

Depends: libc6 (>= 2.3.6-6~), libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libgsl0ldbl (>= 1.9), libmuparser0, liborigin2-1, libpng12-0 (>= 1.2.13-4), libqt4-assistant (>= 4.5.2), libqt4-network (>= 4.5.2), libqt4-opengl (>= 4.5.2), libqt4-qt3support (>= 4.5.2), libqt4-svg (>= 4.5.2), libqt4-xml (>= 4.5.2), libqtcore4 (>= 4.5.2), libqtgui4 (>= 4.5.2), libqwt5-qt4, libstdc++6 (>= 4.2.1), python2.5 (>= 2.5), zlib1g (>= 1:1.1.4), python-qt4, python-central

Save and close and continue on the terminal:

tar -czvf control.tar.gz *
mv control.tar.gz ..
cd ..
ar r qtiplot_0.9.7.8-1_i386.deb control.tar.gz
sudo dpkg -i qtiplot_0.9.7.8-1_i386.deb
sudo apt-get install -f

source code compilation

http://soft.proindependent.com/doc/manual-en/x6344.html#compilation-linux

get requirements Qt (>= 4.5.0), GSL, muParser (1.28), zlib, libpng and BOOST C++

sudo aptitude install qt4-qmake libgsl0-dev libqt4-dev libmuparser-dev zlib1g-dev libpng12-dev libboost-thread1.38-dev libboost-date-time1.38-dev docbook-utils dblatex
cd ~/Downloads
svn checkout svn://svn.berlios.de/qtiplot/trunk qtiplot-svn
cd qtiplot-svn
cp build.conf.example build.conf
gedit build.conf

Open build.conf in your favorite editor. Near the bottom of the same file, either comment out the line indicated above or make sure you have the following additional dependencies installed: Python, SIP and PyQt4

SCRIPTING_LANGS += Python

you also have to comment out GSL entries an comment in GSL system dev files...

Build qtiplot:

qmake && make

Install QtiPlot on your system (you need root privileges):

sudo make install

Resources

Comments